SUMMEWENN mit ODER oder UND – bzw. KLEINER und GRÖSSER

Summewenn

Ich weiß nicht ob ihr viel mit Tabellenkalukulationsprogrammen arbeitet. Es gibt ja Benutzer, die solche Programme als Layout-Satzprogramm für Etiketten benutzen: böser Fehler.

Wenn ihr die also tatsächlich benutzt um damit zu kalkulieren, dann habt ihr vielleicht irgendwann das Problem, dass ihr eine Tabelle nach verschiedenen Werten gruppiert aufsummieren wollt. Und am besten direkt als neue Tabelle, damit man auf der Ursprugstabelle noch immer Werte ändern kann und die dann automatisch in die Gruppierung laufen.

Können Tabellenkalkulationen auch in Einfach und ziemlich dynamisch? Stimmt schon, allerdings meist immer nur eine Gruppierung auf einmal und davon ist dann auch nur schwer ein Diagramm zu erstellen, weil die Urpsrungsdaten ja noch da sind.

Mir hilft dabei immer die Funktion SUMMEWENN.

Der Syntax lautet wie folgt: SUMMEWENN(Bereich; Bedingung, Summenbereich)
Bereich: Ist der Bereich der für die Bedingung geprüft werden soll.
Bedingung: Die Bedingung die erfüllt werden muss.
Summenbereich: Der Bereich, der die Summen enthält.

Beispiele

Praktisch sieht das dann wie folgt aus:

A B C
1 01.01.2014 10 01.02.2014
2 01.02.2014 15 01.04.2014
2 01.02.2014 21
3 01.03.2014 18
4 01.04.2014 22
5 01.05.2014 19

Beispiel 1:
Summe aller Werte in B mit einem Datum „01.02.2014“ in Spalte A:
=SUMMEWENN(A1:A6;“01.02.2014″;B1:B6)
Das Ergebnis lautet: 36
A1:A6 ist der Bereich für die Bedingungen, wenn darin „01.02.2014“ steht wird der Wert aus dem Summenbereich (B1:B6) mit in die Aufsummierung aufgenommen.

Beispiel 2:
Summe aller Werte in B mit einem Datum größer „01.02.2014“ in Spalte A:
=SUMMEWENN(A1:A6;“>01.02.2014″;B1:B6)
Ist wie Beispiel 1. Wichtig ist, dass das „>“ mit in die Anführungszeichen geschrieben werden muss. Außerhalb der Anführungszeichen stehen in den Regeln nur die Bezüge zu Zellen (Also zum Beispiel A1).

Beispiel 3:
Die Überschrift des Beitrages ist ein bisschen verwirrend, denn leider kann SUMMEWENN in keinem Tabellenkalkulationsprogramm, das ich verwende, mit UND oder ODER direkt zusammenarbeiten. Man kann sich aber behelfen, indem man Zwischenergebnisse weiterverwendet und verknüpft. Wir haben in C1 und C2 jeweils ein Datum stehen, und wir wollen jetzt die Summen aus B haben, wenn das Datum größer oder gleich C1 ist und kleiner oder gleich C2.
=SUMME(B1:B6)(SUMMEWENN(A1:A6;“<„&C1;B1:B6)+SUMMEWENN(A1:A6;“>“&C2;B1:B6))
Zur Vereinfachung eingefärbt:
Als erstes bilden wir die Summe alle Werte.
Davon ziehen wir die Summe aller Werte mit einem Datum in A kleiner als der Wert in C1 und die Summe aller Werte mit einem Datum in A größer als der Wert in C2 ab.
Besonders erwähnenswert ist hier der Teil, der sagt „kleiner als der Wert in C1“, denn hier erwartet die Formel eine Zeichenkette, und nur Bezeichner für Zellen dürfen außerhalb der Zeichenkette stehen. Deshalb müssen wir den „<“ und den Bezeichner für die Zelle mit einem „&“ miteinander verbinden. Deshalb „<„&C1. Intern macht die Tabellenkalkulation dann „<01.02.2014“

Wo funktioniert das?

Ich habe es mit LibreOffice Calc 4.2.4.2 verwendet. Wenn ich die Dokumentation von MS Office richtig verstehe, müsste Excel SUMMEWENN ab Version 2003 ebenfalls können.

— der Würschtlmann

Schreibe einen Kommentar

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s